PDA

View Full Version : lurching/shuddering NX when taking foot off accelerator



Pants
17th December 2004, 08:11 AM
For a while now, my NX has been lurching when I switch between putting my foot on the accelerator, and taking my foot off the accelerator. In particular, if I'm in 2nd gear around 3000 revs and take my foot off, it's like the engine is breaking too much, and instead of slowing down gradually, it lurches. This produces a really uncomfortable ride, it's like putting your foot on the brake and then releasing the brake continuously. I usually put my foot down on the clutch to stop this happening. I know it isn't the clutch because I just had this replaced last week, and it was doing this before and after the clutch replacement. I've done a forum search and haven't got any real ideas about what it could be. Does anybody know what could be producing this problem?

Thanks!

NX-TACY
17th December 2004, 10:02 AM
Does this happen only when cold?

Pants
17th December 2004, 11:00 AM
No, although it's worse when cold. I'm wondering could it be a valve or something? I'm thinking I can put up with it for one more year and then I'm replacing the engine to a SR20DET. I would really like to know what it could be though.

NXR
20th December 2004, 09:26 PM
I have the same problem mate. its fucked especially in peak hour traffic. i have to have my foot on the clutch coz it feels like it is going to stall. if u find out what it is i would like to know :-)

Garlo
20th December 2004, 09:51 PM
i have noticed it also but i notice it is worse when a tkae off in a hurry in first

Lonx
20th December 2004, 09:55 PM
Random thought...... you guys checked your throttle sensors are spot on?

j0of
20th December 2004, 09:58 PM
Niroth's Exa did that, But if ure accelerating in 2nd and u stop around 3k rpm, CHUG!, it only started doing it after he put a pod in tho...