REMOVE ADS
+ Reply to Thread
Results 1 to 2 of 2

Thread: High idle after installing Idle control valve

  1. #1
    Newbie stlth15 is very helpful round here
    Join Date
    Mar 2013
    Age
    44
    Posts
    5

    High idle after installing Idle control valve

    Hi guys, well I managed to get track down an idle control valve after getting jack of no cold idle.

    I cut down the log and the air regulator and ICV are installed. All original electrical connections reconnected to air regulator and ICV. The plumb back hose back to the intake manifold after the throttle body connected as well. I also have run a hose back to the intercooler ie: which is the intake after the airflow meter and before the throttle body.

    When I start the car, the idle sits at 1500 RPM!! That is after I adjust the top idle screw all the way in. When I screw out the idle goes higher. It won't drop below this figure. Have checked lines there are no air leaks. Have I plumbed in the connections correctly. I will try and post up some pics of my install. I couldn't put log in original location due to my intercooler piping being in the way.

  2. #2
    Guru Buzz has a brilliant future Buzz has a brilliant future Buzz has a brilliant future Buzz's Avatar
    Join Date
    Nov 2003
    Age
    33
    Posts
    8,259

    sounds like a dead ICV or air reg
    Green is not a colour it's a state of mind!!

    ALL YOUR GREEN M&M'S BELONG TO ME
    ShReXa in the making CLICK HERE

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts