REMOVE ADS
+ Reply to Thread
Results 1 to 4 of 4

Thread: Motor hunting below 2500rpm

  1. #1
    First Time Poster frank1965 is very helpful round here
    Join Date
    Apr 2017
    Age
    52
    Posts
    1

    Question Motor hunting below 2500rpm

    Hard sinerio I am finding, if someone could please help me out.
    All goes well till I want to cruise at 2500rpm or lower, motor wants to hunt and jerk around not wanting to smoothly run. tried looking at a lot of things it could be but has me stumped.
    Seems to be around the very first part of the throttle position, powers all good and runs smoothly up high. Idles well, sometimes when at first crank, it will backfire through the filter once only. Any suggestions on this please.

  2. #2
    I had that issue before, with a Honda, and it was the idle sensor, nit sure if the EXA has that sensor but it look like something with the idle,maybe you are not getting enough gas below 2500 RPM, or maybe is a vacuum hose, the way I test vacuum hoses to see if they are damage is with started fluid. spray started fluid hose by hose and if you see that the car accelerates that hose has a hole, cheers

  3. #3
    EXA/NX Maniac Ant is well respected Ant's Avatar
    Join Date
    May 2006
    Age
    47
    Posts
    182

    Check your detonation sensor, a.k.a knock sensor. From memory the ECU ignores the sensor above about 2500, but below that it will retard the timing every time it thinks the sensor has gone off. You can replace it with a ~600ohm resistor, see if it makes a difference.

  4. #4
    EXALATED Smurf4107 is very helpful round here Smurf4107's Avatar
    Join Date
    May 2008
    Age
    28
    Posts
    1,622

    I agree with Ant - but now that i notice wow Ant your still on here

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts